
NCH Software

ClickCharts Diagram Flowchart 
Software

This user guide has been created for use with

ClickCharts Diagram Flowchart Software Version 8.xx

©NCH Software



Technical Support
If you have difficulties using ClickCharts Diagram Flowchart Software please read the 
applicable topic before requesting support. If your problem is not covered in this user guide 
please view the up-to-date ClickCharts Diagram Flowchart Software Online Technical Support 
at www.nchsoftware.com/chart/support.html. 

If that does not solve your problem, you can contact us using the technical support contacts 
listed on that page.

Software Suggestions
If you have any suggestions for improvements to ClickCharts Diagram Flowchart Software, or 
suggestions for other related software that you might need, please post it on our Suggestions 
page at www.nch.com.au/suggestions/index.html. 

Many of our software projects have been undertaken after suggestions from users like you. 
You get a free upgrade if we follow your suggestion.

www.nchsoftware.com/chart/support.html
www.nch.com.au/suggestions/index.html
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Introduction
Thank you for installing ClickCharts. ClickCharts is a simple, easy-to-use and flexible diagram 
drawing tool.
Features  
● General drawing shapes and symbols for flowcharts, UML and other diagrams.
● Connectors with variant styles and arrow heads.
● Insert images into diagrams. Support many different image formats.
● Detailed control of artistic styles for filling and lining.
● Automatic paper tiling with controllable overlapping.
● Undo/redo editing.
● Open and edit multiple diagrams simultaneously.
● Copy/Paste between ClickCharts documents.
● Export diagram to image files.
● High quality printing.
System Requirements  
Windows XP / Vista / Windows 7 / 8 / 10
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Navigation
Panning 
While holding Space key, click and drag the mouse to move the view. The cursor will change 
to a hand cursor when the Space is held. 
Click and drag the diagram with the middle mouse button to pan. 
Scrolling  
Use Mouse Wheel to scroll the view vertically. 
Use Shift + Mouse Wheel to scroll the view horizontally. 
Zooming 
Use the slider or drop down button on the status bar to change the zooming ratio. 
Point the mouse to the desired spot and use Ctrl + Mouse Wheel  to zoom in/out. 
Fullscreen  
Fullscreen can be enabled when a document is opened. 
From View tab toolbar, click on the Fullscreen  button or press Alt + Enter. Exit using Esc 
key. 
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Diagram Setup
Creating a New Diagram
Use any of the following options to open the template dialog: 
● Select New from the file menu. 
● Enter the keyboard shortcut Ctrl + N 
You can create a new diagram by selecting one of the templates and press OK. 
To create a new blank diagram press Ctrl + B or select New Blank Diagram from the file 
menu. 
Paper Size
Click the Page  button on the Home tab toolbar. 
Use the pull down box to select your paper size. 
Paper Orientation  
Click the Page  button on the Home tab tool bar. 
Click the Landscape or Portrait buttons to select the paper orientation. 
Page Bleed  Page Bleed is used when printing the diagram. A small amount of overlapping at 
the edge of each tile makes it easy to put adjacent tiles together after printing and allows the 
pages to be trimmed to correct printing errors. 

Click the Page  button on the Home tab toolbar. 
Use the slide bar to adjust the size of the bleed. 
Scaling Scaling is used to change the printed size of a chart already designed. Setting the 
scale will change line width and text height, be careful not to make your diagram unreadable. 
Click the Page  button on the Home tab toolbar. 
Use the slide bar to adjust the scale. 
Line Jumps Line jumps are the arcs drawn when one connector crosses other connectors in 
the canvas. 
Click the Page  button on the Home tab toolbar. 
Tick the checkbox to enable for whole document. Option to enable per connector is also 
available in Line dialog. Line jumps are only available for Straight and Orthogonal connectors. 
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General Editing
Context menu Use Right Click to bring up context menu to quickly issue editing commands.
Select a single object 
Click on the visible part of a shape or a line to select the object.
If the object has child object (e.g., text fields), clicking on the child object when the parent 
object is selected will select the child object.
Select multiple objects 
Click and drag to draw a selection rectangle on the screen. Objects encompassed by the 
rectangle will be selected.
Hold down Shift  key to append selected objects to current the selection.
Hold down Control key to add the objects to or remove them from current the selection.
Delete 
Pressing the Delete key when an object is selected will remove the object from the diagram.
Duplicate 
Press Ctrl + D  or select Duplicate under File->Edit to duplicate the selected object.
Find  
Press Ctrl + F  or select Find  under File->Edit to search text inside symbols. 
Center Selected Object(s) 
Press Ctrl + Shift + C or select Center Selected Object(s) under File->Edit to move selected 
object(s) to the center of the canvas.
Copy  
Press Ctrl + C  or select Copy  from the Edit tab toolbar to copy the selected object to the 
clipboard.
Copy Text  
From the context menu, select Copy Text  to copy the selected text to the clipboard. 
Cut  
Press Ctrl + X or select Cut  from the Edit tab toolbar to copy the selected object to the 
clipboard and remove it from the diagram.
Paste 
Press Ctrl + V or select Paste from the Edit tab toolbar to paste the contents of the clipboard 
to the diagram.
Paste without formatting  
From the context menu, Select Paste without formatting  to paste the contents (without the 
format) of the clipboard to the diagram. 
Undo 
Press Ctrl + Z  or select Undo from the Edit tab toolbar to undo the last change.
Redo  
Press Ctrl + Y or select Redo  from the Edit tab toolbar to redo the last undone change.
Select All 
Press Ctrl + A  to select all unlocked objects. If there is only locked objects, all objects will be 
selected. 
Lock/Unlock  
Symbols and text can be locked to keep them in place and turn them unselectable. This 
function serves to not move a symbol or text accidentally when rearranging or moving around 
elements. Likewise, Unlock will release that symbol or text from its unselectable state. 

Copy Properties  
From the context menu, select Copy Properties  to copy the selected object's properties (line, 
fill and font) to the clipboard. 
Paste Properties 
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From the context menu, select Paste Properties to apply the properties (line, fill and font) from 
the clipboard contents to the selected object(s). 
Typing Text 
There are two ways to typing/editing text: 
● Double click the symbol or the text field.
● Click Text button from the tool bar to enter text mode. While in text mode, you can: 

● Click on any space to add a new text object.
● Click on a symbol or a text field to edit or type in the text.
● Click when a green bubble appears to create a new text object attached to a connector. 

The center of the green bubble indicates the attachment point on the connector.
Hyperlinks  
Hyperlink works the same as in usual word editors. 
● To add a hyperlink , type a text with a correct hyperlink  format.
● Go to the hyperlink  by clicking the URL. 
● Clickable hyperlink  is also supported in exported PDF.
Insert Images 
Click on Image  button from the Home tab toolbar, a dialog will popup and allow you to select 
the image file to insert. 
After chosen the image file, click OK to close the dialog. 
And image is load and following the cursor when you move the mouse. Left click when the 
cursor is moved to the appropriate position to place the image. 
Grid/Angle Snapping  
Click Turn on/off snap to grid  button at the right side of the status bar to toggle grid snapping 
on/off. Press and hold Ctrl for alternate snapping. 
When snapping to grid is turned on, position, size and rotation will only increase/decrease at a 
fixed step. This helps users to align objects much more easily. 
Snapping step size (snapping grid size or snapping angle) can be set in Options dialog Edit 
tab. 
Grid line can be shown/hidden by clicking on the grid toggle button (an opened eye with grid 
background) on the status bar.
Object Snapping 
Click Turn on/off snapping to object  button at the right side of the status bar to toggle object 
snapping on/off. Press and hold Ctrl for alternate snapping. 
Functionality is almost the same with snapping to grid, but this option uses the nearest 
object(s) instead as the reference when creating the snap points. 
Snapping to Even Spaces 
This snapping option is automatically enabled when grid and object snapping are both turned 
off. 
What is does is that it takes two objects at a time and creates points before the first object and 
after the second object. When a user places a new object near the created snap points, the 
object will be automatically moved allowing uniform spacing among the objects. 

Groups 
Symbols can be grouped together and treated as a single symbol.
To create a group simply select the symbols you wish grouped and press G.
Groups can be broken up again later by pressing Shift + G .
Open a New Diagram 
A new blank diagram can be opened by clicking the +  button located beside the tab of opened 
projects.
Also, new template window can be opened by holding Ctrl and clicking the +  button located 
beside the tab of opened projects.
Vertically Align 
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To vertically align objects, select the objects, press right click , select Vertically Align, and 
choose any of the options Left edge , Center , and Right edge.
Select Left edge  to align all selected objects to the left most edge.
Select Center  to align all selected objects to the center.
Select Right edge to align all selected objects to the right most edge.
Horizontally Align 
To horizontally align objects, select the objects, press right click , select Horizontally Align, 
and choose any of the options Top edge , Center , and Bottom edge.
Select Top edge  to align all selected objects to the top most edge.
Select Center  to align all selected objects to the center.
Select Bottom edge to align all selected objects to the bottom most edge.
Evenly Space Shapes 
To evenly space objects, select the objects, press right click , select Evenly space shapes , 
and choose between Vertical , or Horizontal spacing.
Select Vertical  to space selected objects from top to bottom.
Select Horizontal to space selected objects from left to right.
Edit with DrawPad Graphic Editor 
To edit inserted image using DrawPad, select Edit with DrawPad Graphic Editor from the 
context menu. 
Edit with PhotoPad Image Editor  
To edit inserted image using PhotoPad, select Edit with PhotoPad Image Editor  from the 
context menu. 
Add Subtopic  
Press Tab to add subtopic in Brainstorming Diagram or select Add Subtopic  from the context 
menu. 
Add Ancestor 
Press Tab to add ancestor in Family Tree Diagram (Person type) or select Add ancestor from 
the context menu. Note that only 2 ancestors can be added per Person symbol 
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Editing Symbols
Place New Symbol  The symbol panel is located in the left sidebar of the main window. 
Click on the Flowchart drop menu at the top of the symbol panel to select the symbol catalog. 
There are two ways to place a symbol into the diagram: 
● Simply drag the symbol from the panel to the diagram area and release the mouse button 

when it's in the right position.
● You can also click to select the symbol on the panel and move the cursor to the diagram 

area. Click again to stamp the symbol onto the diagram.
You can repeat placing the same symbol by hold down Shift  while stamping.

Move Symbol Click and drag a symbol to move it.
Resize Symbol  Select the symbol, drag one of the square dot handles to resize the symbol if 
the handle is enabled (not gray).
Rotate Symbol Select the symbol, move the rotation handle to rotate the symbol if the handle 
is available. To move the center of rotation (indicated by + ), drag +  to the desired location.
Toggle Connection Point Highlighting From the Edit tab toolbar, click Highlight. 
While connection point highlighting is on, connection points will be highlighted while hovering 
the cursor over unselected symbols. 
Add Anchor Point From the Edit tab toolbar, click Add Anchor or press Ctrl + 1 . Click the 
position in the symbol where the new anchor point should be added. 
Right click or press ESC to exit creating anchor mode.
Delete Anchor Point From the Edit tab toolbar, click Delete Anchor  or press Ctrl + 2 . Click 
the anchor point to be deleted from a symbol. 
Right click or press ESC to exit deleting anchor mode.
Move Anchor Point  From the Edit tab toolbar, click Move Anchor  or press Ctrl + 3 . Click 
and drag the anchor point to be moved from a symbol. 
Right click or press ESC to exit moving anchor mode.
Edit Style  
Click on the symbol to select it, then you can: 
● From the Home tab toolbar, click on Fill to change the brush (color or gradient fill) style of 

the symbol. See also Fill Style. 
● From the Home tab toolbar, click on Line to change the brush and line style of the 

symbol's outline. See also Line Style. 
● From the Home tab toolbar, click on Text to type/edit the text in the symbols. 
● From the Home tab toolbar, click on Font to change the text style and alignment. See also 

Font Style. 
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Editing Connectors
Create A Connector  From the Home tab toolbar, click on the Connector  button. 
Click the position in the diagram where the connector starts to place the first end point, then 
drag and drop the mouse at the second point. When dropping the second connector point, the 
connection points on the symbol will appear in blue when the cursor is close to the symbol. 
Once a connection point turns red, releasing the mouse will attach the second end point to that 
connection site. 

Right click or press ESC to exit connector creating mode. 
Editing A Connector  
Click on the line/curve of the connector to select the connector. And then: 
● Move the square dot handle on each end point to move the end and connect/disconnect 

from anchor sites. 
● Depending on the connector style, other handles are available to be moved to change the 

shape of the connector. Please note that non-end point modifications will be automatically 
made when one of the end point(or the connected symbol) is moved. 

Connector Line Style Click on the line/curve of the connector to select the connector. Click 
on Line button from the Home tab toolbar. See Line Style for more information. 
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Fill Style
Select Fill Style  Click one either the No Fill, Solid  or Gradient radio button to select the fill 
style. Operating on other controls after the radio button will also switch to corresponding fill 
style.

No Fill  
When the No Fill  radio button is selected, the shape will not be filled and it will not be 
selectable by clicking on the fill area, you will have to click on the shape's outline. 
Solid 
The shape will be filled with a solid color. 
Click on the color box next to the radio button to change the color. 
Gradient 
The shape will be filled with a gradient. 
The type of the gradient can be select by the pull down control next to the radio button. 
The Direction box lets you change the direction of the gradient. The direction can be changed 
by moving the square dot and/or the arrow head. For a linear gradient, the direction indicates 
the start and end point of the gradient. For a radial gradient, the direction indicates the center 
and radius of the gradient. 

The Stops  bar lets you control the stop points of the gradient. 
● Click on one of the stop points (little triangles on right side of the bar) to select the stop 

point.
● Drag the stop point to move it.
● Right-click on the stop point to delete it or press the X button to delete the selected stop 

point.
● Click on the Stop Point  color box to change the color of the selected stop point.
Sliding the Opacity bar lets you change the opacity of the brush. Slide the bar to the left to 
increase the transparency. 
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Line Style
The Line style has similar options as the fill style. Click on one of the No Line, Solid or Gradi
ent  radio button to select brush style. Operating on other controls after the radio button 
will also switch to corresponding line brush style.
No Line 
If the No Line radio button is selected, no line will be drawn. 
Solid 
Draws the line with a solid color. Click on the color box next to the radio button to change the 
color. 
Sliding the Opacity bar lets you change the opacity of the line. Slide the bar to the left to 
increase the transparency. 
Gradient 
The line will be drawn with a gradient. The type of the gradient can be select by the pull down 
control next to the radio button. 
The Direction box lets you change the direction of the gradient. The direction can be changed 
by moving the square dot and/or the arrow head. For a linear gradient, the direction indicates 
the start and end point of the gradient. For a radial gradient, the direction indicates the center 
and radius of the gradient. 

The Stops  bar lets you control the stop points of the gradient. 
● Click on one of the stop points (little triangles on right side of the bar) to select the stop 

point.
● Drag the stop point to move it.
● Right-click on the stop point to delete it or press the X button to delete the selected stop 

point. 
● Click on the Stop Point  color box to change the color of the selected stop point. 
Sliding the Opacity bar lets you change the opacity of the stop color. Slide the bar to the left to 
increase the transparency. 
Line Width (pt) Type in the Line Width  box or use the up-down arrows to change the width of 
the line. 
Cap Type 
The line cap style changes how the end of the line looks. Select a type from the pull down 
menu to change the line cap style.
Join Type 
The line join style change how two lines are joined together. Select a type from the pull down 
menu to change the line join style.
Dash Type 
The dash style controls whether the line is solid or dashed. Select a type from the pull down 
menu to change the dash style.
Enable line jump 
Draws an arc on the intersection point of a connector and other connectors. Option to enable 
for whole document can be found in Page dialog
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Font Style
Font Click on the Font pull down list to select from different fonts and to change other 
attributes of your text. 
Font Size  
Type in the Text Size edit box or use the up-down arrow to change the font size. 
Bold, Italic and Underline  
Click the Bold , Italic or Underline button to change the text style. 
Font Color 
Click on the color box next to the text style buttons to change the color of the text. 
Alignment 
Click on the alignment buttons to change the text alignments. 
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Arrow Head
Select the connector by clicking on it. 
From the Home tab toolbar, click Arrow  to bring up the arrowhead style options. 
Select the type of the arrowhead from one of the pull down boxes. 
Change arrow head size by dragging the slide bars. 

13



Creating Graphs
Graph The graph feature is an intuitive tool that will help users create engaging graph visuals 
in the most convenient and creative way possible. 
You may select an existing template along with the other chart type examples upon creating a 
new project, or you can start with a blank diagram and choose your graph type symbol(s) 
under the graph menu toolbar. 

Template 
This is where you select existing graph templates. It will automatically show up on the template 
and examples list when you create a blank diagram. You may also select a sample template 
under the graph menu toolbar. 

Import Data 
Here is where you can upload a CSV file to load graph data. You may locate this option under 
the graph menu on the toolbar. 
When it comes to CSV files, the number values should be placed along with the series. 
● A1 (column a, row 1) should always have a value.
● On the first row, the category names should start with B, C and so on.
● On the first column, the series name start on 2, 3, and so on.
● All data should be placed in accordance with the categories.
For additional reference on this aspect, see the table below: 

Assuming that the 
given format has been followed, this is how the chart should look like when importing the CSV: 
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You can manually change the graph type by right clicking the graph itself, then selecting 
"Change Graph Type" from the list such as what is shown below: 

Edit 
Data 

This is where you can enter and customize your current graph data. It can also be found along 
the other options on the graph menu toolbar. 
There are two aspects that you can customize: category  and series . 
Under the category label, you can have a maximum of 12 custom labels. Under the series 
data, you may enter your data manually in accordance with the number of categories and input 
a list name per series. Changing the color that should represent the visuals of your data is also 
possible. 

Title 
Click this option to add or edit the graph title. You may change the font, color, size, orientation, 
etc. upon toggling the title editor. 
Key  
Toggle this option to show or hide the graph keys. The graph keys represent the name and the 
color you have chosen per series. 
Value 
Toggle this option to show or hide the graph values. These are the numbers of the actual data 
that is represented by the visuals. 
Axis  
Toggle this option to show or hide the x-axis and y-axis titles on your graph. 
Switch 
Toggle this option to switch the placements of the row and the column of your graph. Altering 
the placements of the x and y axis will also change the visual representation of your graph 
(e.g. vertical bar graphs will appear horizontal when the switch option is toggled). 
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Font
This option is similar to the title editor. But toggling this option will display the font properties for 
the selected texts within the entire chart. 
Background 
Toggling this option changes your current graph’s background color. You may choose your 
own custom color under the fill color editor. Your background color may be transparent, solid, 
linear gradient, or radial gradient. The level of opacity for the background color may also be 
adjusted. 
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Transform Symbol
Object transformation property popup window 
Object transformation property popup window allows you to type in symbol transformation 
numbers(position, dimension and rotation).
Right-Click on a symbol or a group of symbols, then click on properties to bring up context 
menu.
Select Transform tab, then you can:
Type in the Rotation degrees to change the rotaion angle of the symbol.
Object Position : 
● Type in the Horizontal Position  to change the horizontal alignment of the symbol. 
● Type in the Vertical Position to change the vertical alignment of the symbol. 
Object Dimension: 
● Type in the Height to change the height of the symbol. 
● Type in the Width  to change the width of the symbol. 
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Arrangement Tools
Order Arrangement  
● From the Home tab toolbar, click To Front to bring the selected object to the front. 
● From the Home tab toolbar, click To Back  to send the selected object to the back. 
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Ruler and Guides
Ruler The Ruler appears at the top and left edges of the view. It displays the distance in 
millimeters from the top left corner of the first page. 
Guide lines  Guide lines can be created by Left Clicking on the ruler at the top or left of the 
screen and dragging the line to a location on the document. 
To Move a Guide line Left Click on the line and dragging it to a new location. 
To Hide all Guide lines press Right Click on the line and select Hide all guide lines. 
Showing/hiding guides can also be done via Ctrl + H. 
To Delete all Guide lines press Right Click on the line and select Delete all guide lines. 
Guide lines can be snapped to a grid line by enabling Snapping  before moving the guide line. 
The guide lines main purpose is to provide an additional user defined line that the user can 
snap objects to. 

20



Printing and Exporting Images
Printing 
To print all pages, select File->Quick Print,  or select the Quick Print toolbar item, or use the 
shortcut key combination Ctrl + P 
All symbols and connectors will be printed, on-screen widgets and highlighting will not.
To preview the print, select File->Print, or select the Print toolbar item. 
Exporting Images  
To export an image of your project, select File->Export Image.  Set the resolution for the 
exported images, then browse to the location you want to save and select the file type to save 
in. Your choices are .bmp, .jpg, .png, .svg, .psd, .tga, .tif, .wbmp, .ras, .jp2, .pcx, .gif, .emf and 
.pnm. 

Exporting PDF 
To export your project as a PDF, select File->Export PDF. 
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Auto-Save and Crash Recovery
Auto-Save 
Every minute ClickCharts will automatically save your changed, unsaved file into an auto-save 
folder. When you close ClickCharts and if the diagram have been closed normally, the files in 
the auto-save folder will be automatically removed. 

Auto-Save can be enabled/disabled through Options dialog. The interval of saving files can 
also be set from the dialog. Options dialog can be accessed from the toolbar: by select Edit 
tab and then select Options button, or from the menu: File->Options. 
Crash Recovery  
If ClickCharts crashes or the diagram did not close normally, the files will remain in the 
auto-save folder and will be opened automatically next time ClickCharts runs. Automatically 
opened auto-save files will be removed once they are closed. To keep the recovered file, click 
the File menu and select Save As  to save it into another folder and file name. 
The auto-save folder can be found by following the path (User Documents 
Folder)->"ClickCharts"->"AutoSave". Auto-saved files have ".autosave" inserted after the 
normal file name. To recover an auto-saved file, move it out to another folder and rename it 
with a ClickCharts extension (.ccd). Avoid opening files in the auto-save folder as they will be 
deleted when ClickCharts shuts down normally. 
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Keyboard Shortcuts
Symbol or Action  Key Shortcut  

Alt 
New Ctrl + N 
New Blank Ctrl + B 
Open Ctrl + O 
Close Ctrl + W or Ctrl + F4 
Next Tab Ctrl + Tab 
Previous Tab Ctrl + Shift + Tab 
Save Ctrl + S 
Save as  Ctrl + Shift + S 
Options Ctrl + Shift + O 
Quick Print Ctrl + P 
Exit  Alt + F4 
Select All Ctrl + A 
Cut  Ctrl + X 
Copy  Ctrl + C 
Paste Ctrl + V 
Undo Ctrl + Z 
Redo  Ctrl + Y 
Duplicate Ctrl + D 
Find  Ctrl + F 
Center Selected Object(s) Ctrl + Shift + C 
Group G 
Ungroup  Shift + G 
Lock L 
Unlock  Shift + L 
H-Scroll Shift + Mouse wheel 
V-Scroll Mouse wheel 
Zoom Ctrl + Mouse wheel 
Zoom In  Ctrl + + 
Zoom Out  Ctrl + - 
Pan  Space bar + Mouse click and drag 
Fullscreen  Alt + Enter 
Cancel current operation and select pointer 
tool  

Esc

 Delete Delete 
To Front Page Up 
To Back  Page Down 
Help F1 
Text T
 Font Style  F
 Bold  Ctrl + B(While typing text) 
Italic Ctrl + I(While typing text) 
Underline Ctrl + U(While typing text) 
Filling Style D
 Line Style  S
 Arrow  A
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 Zoom Position Z
 Show / Hide Guide Lines Ctrl  + H
 Straight Connector Shift + S
 Orthogonal Connector Shift + O
 Curve Connector Shift + C
 Orthogonal Rounded Connector  Shift + R
 Straight Yes Connector Shift + Y (Flowchart should be selected)
 Straight No Connector Shift + N (Flowchart should be selected)
 Orthogonal Yes Connector Shift + T (Flowchart should be selected)
 Orthogonal No Connector  Shift + H (Flowchart should be selected)
 Married Connector Shift + M (Family Tree should be selected)
 Divorced Connector Shift + D (Family Tree should be selected)
 One Connector Shift + E (ER Diagram should be selected)
 Many Connector Shift + A (ER Diagram should be selected)
 Participation Connector Shift + P (ER Diagram should be selected)
 Manual Information Connector Shift + U (VSM Diagram should be selected)
 Electronic Information Connector Shift + V (VSM Diagram should be selected)
 Found Message 1 Connector Alt + F (UML Diagram should be selected)
 Found Message 2 Connector Alt + O (UML Diagram should be selected)
 Return Connector Alt + R (UML Diagram should be selected)
 Association 1 Connector Alt + A (UML Diagram should be selected)
 Aggregation 1 Connector  Alt + E (UML Diagram should be selected)
 Composition 1 Connector Alt + C (UML Diagram should be selected)
 Dependency Connector Alt + D (UML Diagram should be selected)
 Generalization Connector Alt + G (UML Diagram should be selected)
 Association 2 Connector Alt + S (UML Diagram should be selected)
 Inner Class Connector Alt + I (UML Diagram should be selected)
 Implementation Connector  Alt + M (UML Diagram should be selected)
 Aggregation 2 Connector  Alt + T (UML Diagram should be selected)
 Composition 2 Connector Alt + P (UML Diagram should be selected)
 Association 3 Connector Alt + L (UML Diagram should be selected)
 Add Anchor Point Ctrl  + 1
 Delete Anchor Point Ctrl  + 2
 Move Anchor Point  Ctrl  + 3
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NCH Software Suite
This is a useful way to browse all the software available from NCH Software
You can see a set of products by type like Audio, Video and so on and view the product. From 
there you can try out the product and it will download and install it for you to trial. If you already 
have the product installed then you can click "Run It Now" and the program will be launched for 
you.

There is also a list of features for products in the category. Click on a feature, such as "Edit a 
Video File", to install a product with that ability.
Search  
Search our website for products matching any keywords you type. 
See more of our software  
Browse our website for more software. 
Subscribe to our newsletter 
You can subscribe to our newsletter for announcements of new releases and discounts. You 
can unsubscribe at any time. 
See the latest discounts for purchase  
See the latest discounts we are offering for purchasing our products. 
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Software License Terms
Our goal is for every user to have a successful experience with our software. We offer it to you 
on the basis that you accept our End User License Agreement (EULA).
This EULA limits our liability and is governed by an arbitration agreement and venue 
agreement. Please read below as these terms affect your rights.
1. The copyrights in this software and any visual or audio work distributed with the software 
belong to NCH Software and others listed in the about box. All rights are reserved. Installation 
of this software and any software bundled with or installed-on-demand from this software, 
including shortcuts and start menu folders, is licensed only in accordance with these terms. 
These copyrights do not apply to any creative work made by you, the user.

2. By installing, using or distributing the software you, on your own behalf and on behalf of your 
employer or principal, agree to these terms. If you do not agree to any of these terms, you may 
not use, copy, transmit, distribute, nor install this software - return it to the place of purchase 
within 14 days to receive a full refund.

3. This software, and all accompanying files, data and materials, are distributed "as is" and with 
no warranties of any kind, whether express or implied except as required by law. If you intend 
to rely on this software for critical purposes you must test it fully prior to using it, install 
redundant systems and assume any risk.

4. We will not be liable for any loss arising out of the use of this software including, but not 
limited to, any special, incidental or consequential loss. Your entire remedy against us for all 
claims is limited to receiving a full refund for the amount you paid for the software.

5. You may not use this software in any circumstances where there is any risk that failure of 
this software might result in a physical injury or loss of life. You may not use this software if you 
do not regularly backup your computer, or do not have antivirus and firewall software installed 
on the computer, or keep sensitive data unencrypted on your computer. You agree to 
indemnify us from any claims relating to such use.

6. You may copy or distribute the installation file of this software in its complete unaltered form 
but you may not, under any circumstances, distribute any software registration code for any of 
our programs without written permission. In the event that you do distribute a software 
registration code, you will be liable to pay the full purchase price for each location where the 
unauthorized use occurs.

7. Use of data collected by the software is subject to the NCH Software Privacy Statement 
which allows automatic anonymized collection of usage statistics in limited circumstances.
8. Choice of Law. If you reside in the United States, your relationship is with NCH Software, 
Inc, a United States company, and this agreement is governed by the laws and courts of 
Colorado. If you reside anywhere in the world outside of the United States, your relationship is 
with NCH Software Pty Ltd, an Australian company, and this agreement is governed by the 
laws and courts of the Australian Capital Territory. Such courts have continuing and exclusive 
jurisdiction over any dispute between you and us, regardless of the nature of the dispute.

9. U.S. Customers Only: Arbitration Agreement and Class Action Waiver: PLEASE READ THIS 
CAREFULLY. IT MAY AFFECT YOUR RIGHTS.
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If you reside in the United States, NCH Software and you agree to arbitrate all disputes and 
claims between us. This agreement to arbitrate is intended to be broadly interpreted. 
References to "NCH" "you," and "us" include our respective subsidiaries, affiliates, agents, 
employees, predecessors in interest, successors, and assigns. This arbitration agreement 
does not preclude you from bringing issues to the attention of U.S. federal, state, or local 
agencies. Such agencies can, if the law allows, seek relief against us on your behalf. This 
Agreement evidences a transaction in interstate commerce, and thus the Federal Arbitration 
Act governs the interpretation and enforcement of this provision. This arbitration provision shall 
survive termination of this Agreement.

A party who intends to seek arbitration must first send to the other, by certified mail, a written 
Notice of Dispute ("Notice"). The Notice to NCH should be addressed to:
Legal Department
NCH Software, Inc.
6120 Greenwood Plaza Blvd, Ste 120
Greenwood Village CO, 80111
USA 
("Notice Address"). The Notice must (a) describe the nature and basis of the claim or dispute; 
and (b) set forth the specific relief sought ("Demand"). If NCH and you do not reach an 
agreement to resolve the claim within 30 days after the Notice is received, you or NCH may 
commence an arbitration proceeding. The amount of any settlement offer made by NCH or you 
shall not be disclosed to the arbitrator.

A. The arbitration will be governed by the Commercial Arbitration Rules and the Supplementary 
Procedures for Consumer Related Disputes (collectively, "AAA Rules") of the American 
Arbitration Association ("AAA"), as modified by this Agreement, and will be administered by the 
AAA. The AAA Rules are available online at adr.org, by calling the AAA at 1-800-778-7879, or 
by writing to the Notice Address. The arbitrator is bound by the terms of this Agreement. All 
issues are for the arbitrator to decide, including issues relating to the scope and enforceability 
of the arbitration provision. Unless NCH and you agree otherwise, any arbitration hearings will 
take place in Greenwood Village Colorado. If your claim is for $10,000 or less, we agree that 
you may choose whether the arbitration will be conducted solely on the basis of documents 
submitted to the arbitrator, through a telephonic hearing, or by an in-person hearing as 
established by the AAA Rules. If your claim exceeds $10,000, the right to a hearing will be 
determined by the AAA Rules. Regardless of the manner in which the arbitration is conducted, 
the arbitrator shall issue a reasoned written decision. NCH will pay all AAA filing, 
administration, and arbitrator fees for any arbitration initiated in accordance with the notice 
requirements above. If, however, the arbitrator finds that either the substance of your claim or 
the relief sought in the Demand is frivolous or brought for an improper purpose then the 
payment of all such fees will be governed by the AAA Rules. In such case, you agree to 
reimburse NCH for all monies previously disbursed by it that are otherwise your obligation to 
pay under the AAA Rules. In addition, if you initiate an arbitration in which you seek more than 
$75,000 in damages, the payment of these fees will be governed by the AAA rules.

B. The arbitrator may award declaratory or injunctive relief only in favor of the individual party 
seeking relief and only to the extent necessary to provide relief warranted by that party's 
individual claim. YOU AND NCH AGREE THAT EACH MAY BRING CLAIMS AGAINST THE 
OTHER ONLY IN YOUR OR ITS INDIVIDUAL CAPACITY, AND NOT AS A PLAINTIFF OR 
CLASS MEMBER IN ANY PURPORTED CLASS OR REPRESENTATIVE PROCEEDING. 
Further, unless both you and NCH agree otherwise, the arbitrator may not consolidate more 
than one person's claims, and may not otherwise preside over any form of a representative or 
class proceeding. If this specific provision is found to be unenforceable, then the entirety of this 
arbitration provision shall be null and void.
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C. Notwithstanding any provision in this Agreement to the contrary, we agree that if NCH 
makes any future change to this arbitration provision (other than a change to the Notice 
Address) you may reject any such change by sending us written notice within 30 days of the 
change to the Arbitration Notice Address provided above. By rejecting any future change, you 
are agreeing that you will arbitrate any dispute between us in accordance with the language of 
this provision.

D. To opt out of this Arbitration Agreement and class action waiver send an Opt Out notice to 
the Notice Address stating "I am electing to opt out of the Arbitration Agreement and class 
action waiver contained in the Legal Terms applicable to my purchase of an NCH product." 
Your Opt Out Notice must include the date and proof of purchase. The Opt Out Notice must be 
postmarked no later than thirty (30) days after the date of purchase. A separate Opt Out Notice 
must be sent for each product purchased.
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Screen References - Email Chart
Sending an Email This dialog allows you to send an email with your current diagram as an 
attachment.
To 
Write the recipient's email address or addresses here.
Subject  
This is the email's subject line.
Message 
Write the body of the email here. The email will be sent in plain text, so no formatting is 
possible.
Attachment Format 
Choose the attachment format that you would like to use for the attachment.
Email Settings 
This opens the Email Settings dialog that lets you choose the proper settings for sending 
emails with ClickCharts. 
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Screen References - Export Image
The Export Image dialog appears before you select the location where you will save an image 
of your diagram. On this dialog, you specify the quality of the image being saved. By default, 
the resolution is set to 72 DPI, which is suitable for reading on most computer screens. If you 
plan on printing your diagram, you may want to enter a value between 240 and 300 for best 
results. A higher resolution will result in a larger image file.

The effect of not using a background color depends on the output format. For image format 
that support transparency, for example PNG format, the background will become transparent 
while no background color is used. Otherwise the white background will be used.

Resolution 
Output image resolution (DPI).
Margin 
Space on the edge of the image in pixels.
Transparent  
Click to set the background to transparent.
Color 
Click to select the color to be used as the background color.
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Screen References - Send Email Dialog

Send An Email
The Send Email Dialog sends an email automatically. Email settings will need to be set up 
before an email can be sent. If you have not already done so, you will be prompted for your 
email settings before proceeding. 

Email Options
   -Send To

   -Enter the email address(es) of the recipient(s). Put a comma between each email address.
   -Subject
   -Any text entered into this field will appear as the subject of the email.
   -Body
   -Any text entered into this box will appear as the body of the email.
   -Footer
   -Any text entered into this box will appear at the very end of the email. This may require a 
purchase to enable changing it.
   -Settings
   -Clicking this button will open the Email Settings dialog window, where changes can be 
made to the email server, sending address, etc.
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Screen References - Color Picker Dialog
Color Picker Dialog  
The color picker is divided into multiple parts, with several ways available to choose a color: 
Visually Adjusting Color  

The top half of the dialog consists of 2 colored boxes, one that lets you pick any point in a 
256 x 256 square and the other that works as a long slider. Which colors are displayed in 
these two boxes depends on which radio button is selected (see below), but in all cases the 
position of the slider will change the colors available in the square box. Which ever point is 
selected in that square box is the selected color. 

Adjusting by RGB or HSV 
Underneath the square colored box, there is a series of 6 options (1 each for hue, 
saturation, value, red, green, and blue) that each contains a radio button, a slider, and an 
up-down number control. If one of the 3 HSV radio buttons is selected, that value will be 
represented by the visual slider (see above) while the other two values will be the axes of 
the square color box. The controls work the same way if one of the RGB radio buttons is 
selected. You can also adjust these values with the sliders provided next to the labels, as 
well as the up/down controls next to the sliders. Any adjustment of these values will update 
the visual controls, and any adjustment of those visual controls will update these values. 

Selected Color 
The selected color is displayed to the right of the RGB and HSV controls. The box is split 
diagonally, with the upper left section labeled New (the color you are creating), and the 
bottom right section labeled Current (the color that already exists, and will continue to be 
selected if you Cancel the dialog). Beneath that is the Hex Value of the selected color (you 
can also enter any valid hex value there to update the selected color). There is an 
eyedropper button to the right of the selected color that will allow you to set the selected 
color by sampling anywhere on the desktop. 

User-defined Color Palette  
At the bottom of the dialog you will find a series of 12 colored rectangles alongside a button 
titled Set to Swatch. These comprise the user-defined color palette, and allow you create 
and save (these will persist even when ClickCharts is closed) your own custom colors. To 
set a swatch's color, first select that swatch by clicking it. Then choose your desired color, 
and finally click the Set to Swatch button. You can then load any of the saved colors by 
simply clicking on that swatch. 
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Screen References - Select Template
ClickCharts includes several templates to help you get started. You can open the Templates 
dialog by clicking New on the Home toolbar. To select a template, select a folder from the list 
on the left and then click on a template on the right to select it. Click OK to open the template 
for editing. Available templates are the following: 
Flowcharts 
- Cab Booking - Swimlane 
- Consensus Decision Making 
- Credit Card Payment 
- Flowchart Template 
- Front Office Operations - Swimlane 
- Hiring Process 
- Multi Department Flowchart 
- Sale Approval 
UML Diagrams 
- Activity Diagram 
- Class Diagram 
- Use Case Diagram 
ER Diagrams 
- Database 
- Diagram - Library Management System 
- Diagram Template 
Data Flow Diagrams 
- Data Flow Diagram Template 
- Elections 
- Order Processing 
Organizational Charts 
- Org Chart - Business 
- Org Chart Template - High School 
- Org Chart Template 
Venn Diagrams 
- Activity Venn Diagram 
- Marketing Venn Diagram 
- Venn Diagram 
Block Diagrams 
- General Communication System 
- Von Neumann architecture 
Brainstorming Diagrams 
- Business Plan 
- Eating Plan 
- Exam Preparation 
- Grade 6 Speech Preparation 
- Leadership Qualities 
Mind Map Diagrams 
- Career Orientation 
- Estate Planning 
- Fire Safety Enforcement 
- Mind Map 
- Personal Goals 
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- School Magazine 
- Travel Itinerary 
- Types of English 
- Webinar UX 
- Website 
BPMN Diagrams 
- BPMN - Billing 
- BPMN - Invoice 
- BPMN - Payroll 
- BPMN - Purchase 
Family Tree Diagrams 
- My Family (Family Chart 1) 
- Four Generation Family Tree (Family Chart 2) 
- Four Generation Family Tree (Family Chart 3) 
- Ancestor Chart (Family Chart 4) 
- Pedigree Chart (Family Chart 5) 
- My Family (Family Chart 6) 
- Kinship Diagram 
Electrical Diagrams 
- Schematic Diagram 1 
- Schematic Diagram 2 
- Schematic Diagram 3 
- Schematic Diagram 4 
- Wiring Diagram 
- Motor Control Circuit 
Fishbone Diagrams 
- Fishbone Diagram 1 
- Fishbone Diagram 2 
- Fishbone Diagram 3 
- Fishbone Diagram 4 
Network Diagrams 
- Cisco Network - Call Center 
- Cisco Network - Multi-user 
- Cisco Network - Two-line Phone 
VSM Diagrams 
- VSM - Bank Loan 
- VSM - Grocery Delivery 
- VSM - Lean Business 
Process Flow Diagrams 
- PFD - Engineering Process Flow 1 
- PFD - Engineering Process Flow 2 
- Process Flow 1 
- Process Flow 2 
Piping and Instrumentation Diagrams 
- PID - Desulfurizing Boiler Plant 
- PID - Rankine Cycle 
Bubble Diagrams 
- Bubble - Employee Satisfaction 
- Bubble - Interior Design 
- Bubble - Sales Graph 
Wireframe Diagrams 
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- Android - Alarm 
- Android - Email 
- Android - Registration 
- Android - Settings 
- Website - Ecommerce 1 
- Website - Ecommerce 2 
- Website - News 
- Website - Registration 
- Website - Prototype 
- Windows - Settings 1 
- Windows - Settings 2 
- Windows - Uploads 
- iOS - iPad 
- iOS - iPhone 
Chemistry Diagrams 
- Chemistry 1 
- Chemistry 2 
- Chemistry 3 
- Chemistry 4 
Probability Tree 
- Probability Tree 1 
- Probability Tree 2 
- Probability Tree 3 
Graphs 
- Bar Graph 1 
- Bar Graph 2 
- Column Graph 1 
- Column Graph 2 
- Donut Graph 1 
- Donut Graph 2 
- Line Graph 1 
- Line Graph 2 
- Pie Graph 1 
- Pie Graph 2 
- Scatter Plot 1 
- Scatter Plot 2 
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Screen References - Print Preview
Print preview dialog allows you to view individual pages before printing, set page size, set 
orientation, set bleeding, fit the diagram to a single page and skip printing blank pages. You 
can also click on PDF... to save your chart as a .pdf document. To open this dialog select File-
>Print,  or select the Print toolbar item. 
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Screen References - Options ~ General
Startup
Show welcome dialog on startup
Enable/disable welcome dialog on application startup.
Auto Save
Enable Auto-Save
Enable/Disable Auto-Save.
Auto-Save Interval (Minutes):
Auto-Save interval in minutes.
Default file name
Reset
Reset filename to default: Untitled + suffix 'autonumber' 
Reset Auto Number
Reset the suffix autonumber to 0
Note: Snapping can be turned on or off by clicking the magnet icon in the lower right bar of the 
main window (next to the zoom control), or can be overridden while placing an object or 
rotating by pressing and holding the Shift key. 
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Screen References - Options ~ Canvas
Rulers and Grids
Units of measurement:
Select from a list the units to be used.
Snapping Grid Size:
Enter the distance between grid lines.
Snapping Angle (degrees):
Enter the degrees the rotation handle should snap objects to as you rotate. 
Auto Connect
Enable auto connect new symbol
Enable/disable automatically connecting a new symbol to the last symbol added to the 
document.

38



Screen References - Options ~ Text
Resize text when shape is resized
Enable/disable automatic resizing of the text when the height or width of its shape is changed.
Automatically size text to fit shape
Enable/disable automatic resizing of the text to fit within its shape. Resizing text only applies 
when resizing the symbol containing the text.
Match the size of all text inside symbols
When text inside a symbol is changed, enable/disable automatic resizing of the remaining text 
inside symbols
Default Font Properties
Font Size:
Select default text font size inside symbols or connectors
Font:
Select default font inside symbols or connectors
Reset to Default
Reset font settings to default
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Screen References - Options ~ Shape
Default Line Color:
Set the default line color when creating new symbols
Default Line Width:
Set the default line width when creating new symbols
Default Dash Type:
Set the default line dash type when creating new symbols
Reset to Default
Reset shape line settings to default
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