NCH Software
Express Rip CD Ripper Software
This user guide has been created for use with
Express Rip CD Ripper Software Version 5.xx

©NCH Software

Technical Support
If you have difficulties using Express Rip CD Ripper Software please read the applicable topic
before requesting support. If your problem is not covered in this user guide please view the
up-to-date Express Rip CD Ripper Software Online Technical Support at
www.nch.com.au/rip/support.html.
If that does not solve your problem, you can contact us using the technical support contacts
listed on that page.

Software Suggestions
If you have any suggestions for improvements to Express Rip CD Ripper Software, or
suggestions for other related software that you might need, please post it on our Suggestions
page at www.nch.com.au/suggestions/index.html.
Many of our software projects have been undertaken after suggestions from users like you.
You get a free upgrade if we follow your suggestion.
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Overview
Express Rip is a program for Windows that lets you extract digital audio tracks from audio CDs
directly into a variety of audio file formats. By using direct digital extraction, pure audio quality
is maintained. At the time of release, Express Rip was determined to be the fastest free CD
ripper available.
Features
●
Converts audio CD tracks into a variety of file formats, such as Wave, MP3, Ogg Vorbis
and AAC (some formats only available in Plus version).
●
High speed and quality CD digital audio extraction (ripping).
●
Automatically updates the displayed track-list when a CD is ejected or inserted.
●
Can optionally download Album and Track information from the Internet.
●
Simple, easy to use interface.
System Requirements
●
Windows XP/2003/Vista/Windows7 and 8/Windows10
●
Pentium 300MHz or above with at least 16MB RAM (32MB for 2000/XP/2003)
●
CD-ROM drive
Express Rip is just one component of the NCH Software suite of audio software for business. If
you have not done so already, please visit www.nch.com.au/software to download many other
audio related programs.
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General Usage
Audio CD Detection
When Express Rip is started it will automatically detect any Audio CDs in all CD-ROM drives.
The main display will list all track names and durations for the CD in the first drive. Any time
you eject a CD or load a new one, Express Rip will detect this and refresh the display.
Note: If Express Rip does not detect any tracks on your CD, or the tracks have strange looking
names, please verify your audio CD files have a .cda file extension. If they do not, then
Express Rip will not be able to properly read the audio files. In such situations, it is likely the
files are stored as data on your CD, so you should be able to use File Explorer to copy and
paste the files from the CD to your hard drive.
Note: You cannot run Express Rip in Restricted User mode due to limitations in how Windows
deals with CD drives.
Track Naming
If you have an active Internet connection, a cddb Internet lookup will be performed on all
inserted CDs by default, to attempt to retrieve the names of the album, artist and all the tracks
(see Program Options for more details). If you do not have an Internet connection or if the
lookup cannot be performed for whatever reason, the track names will default to "Track xx",
where "xx" is the number of the track. If you wish to change the names, you can do so by
clicking on a track and selecting File -> Rename Track from the menu.
NOTE: Under standard Windows naming conventions, the following characters are not
permitted to be used in file names:
\/:*?"<>|
If any of the above characters are detected, they will be removed.
Selecting Tracks to Extract
The main window lists all audio tracks on the CD in the selected drive, each with a checkbox
positioned on its left. For every track you wish to extract to your hard drive, simply click on its
respective checkbox. If you change your mind and do not wish to extract a selected track,
simply click its checkbox again to deselect it.
To select all tracks, either click Select -> Select All from the menu or press Ctrl+A on the
keyboard.
To deselect all tracks, either click Select -> Unselect All from the menu or press Ctrl+U on the
keyboard.
If you wish to play a track at any time, you can do so by selecting the track and either clicking
the "Play" button, or pressing the F9 key.
Selecting the Output File Format
Next to the text labeled "Output Format" is a list of formats to which you can extract the audio
tracks. The choice of formats is as follows:
●
.WAV
●
.MP3
●
.AU (Plus version only)
●
.AIFF (Plus version only)
●
.AIFC (Plus version only)
●
.AIF (Plus version only)
●
.GSM (Plus version only)
●
.VOX (Plus version only)
●
.RAW (Plus version only)
●
.OGG (Plus version only)
●
.AAC (Plus version only)
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.M4A (Plus version only)
.FLAC (Plus version only)
●
.MPC (Plus version only)
●
.RSS (Plus version only)
●
.SPX (Plus version only)
●
.WMA (Plus version only)
●
.AMR (Plus version only)
●
.APE (Plus version only)
●
.CAF (Plus version only)
Track Extraction
When the tracks are extracted, they will be stored in the output folder specified in the "Output
Folder" box, and given the same names as shown in the main list (appended by the
appropriate file extension - see Program Options section). If you wish to change the folder in
which to store the files, simply click on the "Browse" button adjacent to the Output Folder box,
and select a new folder in the browser windows that opens.
Single Track or Multiple Track Output
You can select if all the selected tracks will be ripped to separate files (default) or if they will all
be ripped to one file named 'AllTracks'. To do this select the File menu and select the option
you desire.
●
●
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Program Options
You can open the Program Options Dialog Box by clicking the "Options" button or by selecting
File -> Options from the menu.
Online Album Database
The option 'Access cddb Internet Server for Album Details' will use your Internet connection to
access Album and Track name details from the cddb online database. The audio track list will
be automatically updated with the retrieved names.
If you have selected the cddb Internet lookup option, the Filename Format radio buttons allow
you to select the naming format of the output files. You can choose between using the
following formats:
1. Artist - TrackName.ext
2. Album - Artist - TrackName.ext
3. Custom Setup (Express Rip Plus feature only) (see below)
The Custom Setup is an advanced setting that allows you to decide how the output files will be
stored on your computer. This involves the writing of a string of characters that denote
information related to the audio CD. An example of how to write a string is as follows:
[%a - %b - %g]\{%n. %t - %y}
This will extract your audio CD tracks to a folder named "Artist - Album - Genre", with filenames
structured as "Tracknumber. Trackname - Year".
All the arguments that can be used to form the custom string are as follows:
●
%a - the artist name
●
%b - the album name
●
%e - extra track information (may not exist in all cases)
●
%g - the genre of the album (e.g., rock, jazz)
●
%n - the track number in 2-digit form (the first track listed on the CD will be track number
01)
●
%t - the name of the extracted track
●
%y - the year the album was released
●
[] - anything inside these brackets will be treated as a folder
●
{} - anything inside these brackets will be treated as a filename
Note that you can have multiple levels of folders set up, but you are only allowed to have one
filename specified in the string.
File Overwrite Options
Select the course of action to take when the destination file exists while converting files. The
options are:
●
Prompt me for what to do
●
Always overwrite (replace existing files)
●
Never overwrite (leave existing files)
●
Cancel the entire process
Note that "Prompt me for what to do" will prompt only once every time the ripping process is
started. Whatever decision is made at the prompt will be applied to subsequent files.
Other Options
ID3 tag information may be added to the internal file information of ripped mp3 files.
Show a complete dialog after ripping complete. You have the options of 'Eject CD' and 'Open
the output folder'.
You may select if the CD is ejected after ripping is complete to make it easier to rip another CD.
After ripping is complete, this option will display a dialog confirming the rip is complete.
If required, the CD can be ripped as a single track rather than multiple tracks.
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You may add a short silence to the start of the track to reduce 'popping' artifacts on some mp3
players.
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Shortcut Keys References
●
●
●
●
●
●
●
●
●
●
●
●

F2 - Rename Selected Track
F9 - Play Selected Track
F10 - Stop the Currently Playing Track
Ctrl+A - Select All Tracks
Ctrl+U - Clear All Track Selections
Ctrl+E - Eject CD in selected drive
Ctrl+L - Load CD into selected drive
Ctrl+R - Rip Selected Tracks
Ctrl+O - Open Program Options
Ctrl+F - Refresh Album Information (i.e., reload from disc and/or from cddb)
F1 - Open Help Documentation
Alt+F4 - Quit Express Rip
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Command Line Options
You can run Express Rip from the Windows command line. Any or all options can be used and
repeated as needed. No prompts occur when using command line options. Rip settings and
other such options will default to the last used setting. The following options are available:
-rip Rip all tracks to the output folder.
-drive Select the drive letter (e.g., D) to rip from.
-hide Hides Express Rip.
-show Reveals the Express Rip window.
-outputfolder Folder to rip the tracks to
-separatetracks Rip each selected track separately
-onetrack Rip all selected tracks as one file
-exit Exit Express Rip
For the Unified NCH API
-gettrackcount Returns a count of audio tracks on the CD
-getalbumname Returns the name of the album
-getartistname Returns the artist name
-gettrackname Returns the trackname
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Volume Change
You can increase or decrease the volume of the output file. The range you can choose is from
-32db to 20db
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Express Burn
Create and record audio CDs on Windows or Mac. Express Burn is the fastest CD/DVD writing
program in the world.
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Switch
Convert and encode audio files from many different file formats on Windows or Mac.
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Purchasing and Registering Express Rip Plus
Express Rip Plus requires purchase and registration of a license for each installation. You can
view current pricing information at www.nch.com.au/rip/register.
Once you have obtained your registration, select File -> "Register Express Rip Plus" from the
menu, and enter your registration details exactly as provided.
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NCH Software Suite
This is a useful way to browse all the software available from NCH Software
You can see a set of products by type like Audio, Video and so on and view the product. From
there you can try out the product and it will download and install it for you to trial. If you already
have the product installed then you can click "Run It Now" and the program will be launched for
you.
There is also a list of features for products in the category. Click on a feature, such as "Edit a
Video File", to install a product with that ability.
Search
Search our website for products matching any keywords you type.
See more of our software
Browse our website for more software.
Subscribe to our newsletter
You can subscribe to our newsletter for announcements of new releases and discounts. You
can unsubscribe at any time.
See the latest discounts for purchase
See the latest discounts we are offering for purchasing our products.
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Opus Encoder Options
Encode audio into the Opus format.
Bitrate
Target bitrate in kbit/sec (6-256 per channel) In VBR mode this specifies the average rate for a
large and diverse collection of audio. In CVBR and Hard-CBR mode it specifies the specific
output bitrate. Default for >=44.1kHz input is 64kbps per mono stream, 96kbps per coupled
pair.
Use default bitrate encoding
In default mode, encoder will choose bitrate automatically. For >=44.1kHz input is 64kbps per
mono stream, 96kbps per coupled pair.
Use variable bitrate encoding
In VBR mode the bitrate may go up and down freely depending on the content to achieve more
consistent quality.
Use constrained variable bitrate encoding
Outputs to a specific bitrate. This mode is analogous to CBR in AAC/MP3 encoders and
managed mode in vorbis coders. This delivers less consistent quality than VBR mode but
consistent bitrate.
Use hard constant bitrate encoding
With hard-cbr every frame will be exactly the same size, similar to how speech codecs work.
This delivers lower overall quality but is useful where bitrate changes might leak data in
encrypted channels or on synchronous transports.
Down mix (None)
Don't down mix, keep the channels same as source.
Downmix to mono
Force to Downmix to mono.
Downmix to stereo
Downmix to stereo if input channels > 2.
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Software License Terms
Our goal is for every user to have a successful experience with our software. We offer it to you
on the basis that you accept our End User License Agreement (EULA).
This EULA limits our liability and is governed by an arbitration agreement and venue
agreement. Please read below as these terms affect your rights.
1. The copyrights in this software and any visual or audio work distributed with the software
belong to NCH Software and others listed in the about box. All rights are reserved. Installation
of this software and any software bundled with or installed-on-demand from this software,
including shortcuts and start menu folders, is licensed only in accordance with these terms.
These copyrights do not apply to any creative work made by you, the user.
2. By installing, using or distributing the software you, on your own behalf and on behalf of your
employer or principal, agree to these terms. If you do not agree to any of these terms, you may
not use, copy, transmit, distribute, nor install this software - return it to the place of purchase
within 14 days to receive a full refund.
3. This software, and all accompanying files, data and materials, are distributed "as is" and with
no warranties of any kind, whether express or implied except as required by law. If you intend
to rely on this software for critical purposes you must test it fully prior to using it, install
redundant systems and assume any risk.
4. We will not be liable for any loss arising out of the use of this software including, but not
limited to, any special, incidental or consequential loss. Your entire remedy against us for all
claims is limited to receiving a full refund for the amount you paid for the software.
5. You may not use this software in any circumstances where there is any risk that failure of
this software might result in a physical injury or loss of life. You may not use this software if you
do not regularly backup your computer, or do not have antivirus and firewall software installed
on the computer, or keep sensitive data unencrypted on your computer. You agree to
indemnify us from any claims relating to such use.
6. You may copy or distribute the installation file of this software in its complete unaltered form
but you may not, under any circumstances, distribute any software registration code for any of
our programs without written permission. In the event that you do distribute a software
registration code, you will be liable to pay the full purchase price for each location where the
unauthorized use occurs.
7. Use of data collected by the software is subject to the NCH Software Privacy Statement
which allows automatic anonymized collection of usage statistics in limited circumstances.
8. Choice of Law. If you reside in the United States, your relationship is with NCH Software,
Inc, a United States company, and this agreement is governed by the laws and courts of
Colorado. If you reside anywhere in the world outside of the United States, your relationship is
with NCH Software Pty Ltd, an Australian company, and this agreement is governed by the
laws and courts of the Australian Capital Territory. Such courts have continuing and exclusive
jurisdiction over any dispute between you and us, regardless of the nature of the dispute.
9. U.S. Customers Only: Arbitration Agreement and Class Action Waiver: PLEASE READ THIS
CAREFULLY. IT MAY AFFECT YOUR RIGHTS.
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If you reside in the United States, NCH Software and you agree to arbitrate all disputes and
claims between us. This agreement to arbitrate is intended to be broadly interpreted.
References to "NCH" "you," and "us" include our respective subsidiaries, affiliates, agents,
employees, predecessors in interest, successors, and assigns. This arbitration agreement
does not preclude you from bringing issues to the attention of U.S. federal, state, or local
agencies. Such agencies can, if the law allows, seek relief against us on your behalf. This
Agreement evidences a transaction in interstate commerce, and thus the Federal Arbitration
Act governs the interpretation and enforcement of this provision. This arbitration provision shall
survive termination of this Agreement.
A party who intends to seek arbitration must first send to the other, by certified mail, a written
Notice of Dispute ("Notice"). The Notice to NCH should be addressed to:
Legal Department
NCH Software, Inc.
6120 Greenwood Plaza Blvd, Ste 120
Greenwood Village CO, 80111
USA
("Notice Address"). The Notice must (a) describe the nature and basis of the claim or dispute;
and (b) set forth the specific relief sought ("Demand"). If NCH and you do not reach an
agreement to resolve the claim within 30 days after the Notice is received, you or NCH may
commence an arbitration proceeding. The amount of any settlement offer made by NCH or you
shall not be disclosed to the arbitrator.
A. The arbitration will be governed by the Commercial Arbitration Rules and the Supplementary
Procedures for Consumer Related Disputes (collectively, "AAA Rules") of the American
Arbitration Association ("AAA"), as modified by this Agreement, and will be administered by the
AAA. The AAA Rules are available online at adr.org, by calling the AAA at 1-800-778-7879, or
by writing to the Notice Address. The arbitrator is bound by the terms of this Agreement. All
issues are for the arbitrator to decide, including issues relating to the scope and enforceability
of the arbitration provision. Unless NCH and you agree otherwise, any arbitration hearings will
take place in Greenwood Village Colorado. If your claim is for $10,000 or less, we agree that
you may choose whether the arbitration will be conducted solely on the basis of documents
submitted to the arbitrator, through a telephonic hearing, or by an in-person hearing as
established by the AAA Rules. If your claim exceeds $10,000, the right to a hearing will be
determined by the AAA Rules. Regardless of the manner in which the arbitration is conducted,
the arbitrator shall issue a reasoned written decision. NCH will pay all AAA filing,
administration, and arbitrator fees for any arbitration initiated in accordance with the notice
requirements above. If, however, the arbitrator finds that either the substance of your claim or
the relief sought in the Demand is frivolous or brought for an improper purpose then the
payment of all such fees will be governed by the AAA Rules. In such case, you agree to
reimburse NCH for all monies previously disbursed by it that are otherwise your obligation to
pay under the AAA Rules. In addition, if you initiate an arbitration in which you seek more than
$75,000 in damages, the payment of these fees will be governed by the AAA rules.
B. The arbitrator may award declaratory or injunctive relief only in favor of the individual party
seeking relief and only to the extent necessary to provide relief warranted by that party's
individual claim. YOU AND NCH AGREE THAT EACH MAY BRING CLAIMS AGAINST THE
OTHER ONLY IN YOUR OR ITS INDIVIDUAL CAPACITY, AND NOT AS A PLAINTIFF OR
CLASS MEMBER IN ANY PURPORTED CLASS OR REPRESENTATIVE PROCEEDING.
Further, unless both you and NCH agree otherwise, the arbitrator may not consolidate more
than one person's claims, and may not otherwise preside over any form of a representative or
class proceeding. If this specific provision is found to be unenforceable, then the entirety of this
arbitration provision shall be null and void.
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C. Notwithstanding any provision in this Agreement to the contrary, we agree that if NCH
makes any future change to this arbitration provision (other than a change to the Notice
Address) you may reject any such change by sending us written notice within 30 days of the
change to the Arbitration Notice Address provided above. By rejecting any future change, you
are agreeing that you will arbitrate any dispute between us in accordance with the language of
this provision.
D. To opt out of this Arbitration Agreement and class action waiver send an Opt Out notice to
the Notice Address stating "I am electing to opt out of the Arbitration Agreement and class
action waiver contained in the Legal Terms applicable to my purchase of an NCH product."
Your Opt Out Notice must include the date and proof of purchase. The Opt Out Notice must be
postmarked no later than thirty (30) days after the date of purchase. A separate Opt Out Notice
must be sent for each product purchased.
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