Beat Designer

The Beat Designer is a utility which lets you build a beat track for your project. To open the beat designer, click the Beat Designer button on the Tools tab. To help get you started, there is a kit of sounds and patterns available for free download - just click on File->Download Kits and Patterns.

Tool Panel

The tool panel is located in the bottom-left corner beside the timeline and contains controls for adjusting the tempo (BPM), time signature and length (in bars) of the beat clip you are creating. Changing their value will change the scale of the timeline.

Beat Divisions

You can subdivide each beat in a track to create smaller beat durations. So, for your kick drum you may have a kick every 1/4 quarter note, but for your hi-hat you may have a hit every 1/8 note. To change the beat divisions click on the spanner icon of the track and change the number of divisions.

Adding a Beat

The sound a track makes is determined by the sound that is assigned to it. You can create and manage sounds using the Sound tab from the main toolbar. You can assign a sound to a track by clicking on the button with the trumpet icon. You add sounds to your track by simply clicking on the division you would like to place a sound.

Adjusting the Volume

You can change the volume of each individual sound by dragging the small fader control in the centre of each beat up or down. If the sound you are using consists of only one file then the volume will be attenuated by processing the audio. You can however configure your sound to use multiple files assigned to different volume ranges. In this case MixPad will choose the file which most closely fits the fader volume and then apply further processing to adjust the volume as required.

Tapping a Rhythm

If you'd like to tap a rhythm into the Beat Designer while playing back, you can bind a key to each track so that when you hit the key, a sound will be placed in the division at the current cursor position. You can assign a key binding by clicking on the spanner icon of the track.

Loading your Beat Clip Back Into MixPad

Once you are finished building your beat clip, click the Create Clip button on the toolbar and MixPad will create a new audio clip in the selected track of MixPad's main window.

Pattern Library

A pattern is just a sequence of events played across the tracks of your beat clip. You can save and load your favorite patterns from the pattern library by using the Save Pattern and Load Pattern buttons. Patterns can be re-used with different sounds and kits. So you may have a standard 4/4 rock pattern that you like to begin with, but you can change it up quickly by assigning different sounds to the tracks.

Kit Library

A kit contains a list of sounds configured for each track. Saved kits can be loaded into the Beat Designer by selecting the kit from the library list at the left side of the Beat Designer. At any time, you can save your current configuration as a new kit using the Save Kit button.

Managing Sounds

You can create and modify your library of sounds using the Sound tab.

The simplest form of a sound consists of a single audio file. This file will then be used for all volume ranges. You can create a more sophisticated sound by assigning different files to different volume ranges. For example you may have a recording of a cymbal being hit at different strengths. You can load all these files and then assign each file to its own volume range. Now when this sound is used, MixPad will use the file belonging to the correct volume range. Doing this can give a more natural sound to your audio.

Humanize

The Humanize tool introduces minor randomised timing errors to the onset of each beat to make it sound more like a human is playing rather than a machine. Click the Humanize button on the Tools tab and adjust the degree of error you want to introduce, then click the Humanize button to apply. Setting the degree of error to 0 will clear all errors.

Quantize

Quantizing is the reverse of humanizing. It will re-align all your beat sounds to exactly on the beat grid. Clicking this button is the same as using the Humanize feature and setting the degree of error to 0.